Execute SMC3_ReinitDrive After Change Gear ratio of the Servo motor

Motion
drsumruay
2019-11-15
2019-11-29
  • drsumruay

    drsumruay - 2019-11-15

    Hi, Everyone

    I found some problem with the SMC3_ReinitDrive Function Blocks. So when I execute this, It always keeps the state to busy.
    It doesn't seem to be done.

    Am I missing about this?

    Please guide me on how to fix it.

    With regards.

    IMG: Untitled.png

     
  • eschwellinger

    eschwellinger - 2019-11-16

    Hi,
    which drive is this?
    I think you need to check the logger, there you should see why the slave hangs on startup.
    (maybe could not switch ethercat op mode)

    BR
    Edwin

     
  • drsumruay

    drsumruay - 2019-11-23

    Thanks, Edwin
    The log of the device doesn't show any info for this problem.

    The drive is Fuji Servo type: RYT101D5-VC2-Z88(EtherCAT)

    IMG: prob1.png

     
  • eschwellinger

    eschwellinger - 2019-11-27

    Hi,
    is this drive DS402 compliant?
    Then I would try to do it that way:
    l viewtopic.php?t=6254 l

    If you add the ESI file I would check if this might possible.
    BR
    Edwin

     
  • drsumruay

    drsumruay - 2019-11-28

    Hi,
    Edwin
    The driver supports DSP402.

    I 've attached the XML file of the servo drive:

    if you need more information to solve this problem, please let me know

    With Regards

    IMG: Untitled.png

    RYT VC2 Z50_5000_0001.xml [90.14 KiB]

     
  • eschwellinger

    eschwellinger - 2019-11-29

    Hi,
    with attached ESI it looks that way:

    So my question is, where does it fail...
    you could set:
    SM3_BASIC_LOG_ACYCLIC_COM
    as compiler define ( righclick on the application and add this as compiler define)
    Then check the logger... in the situation it fails.

    BR
    Edwin

    IMG: Alpha5.png

     

Log in to post a comment.