Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Unable to connect to this device

  • djesic

    djesic - 2019-07-25


    I installed CODESYS Control for Raspberry PI package and managed to connect to my Raspberry Pi via Ethernet and install the service (MC version).
    I then tried running the Webvisu example project but when on the Device tab, I select "Scan network..." and select my Raspberry from the list, I get the following message:

    "Setting the active path has been aborted.
    The selected device is either unavailable or its target ID or target type does not match the device in your project. You will not be able to connect to this device."

    Is there something that I've missed?

    Thank you for your help


    JAPIB - 2019-07-25

    A stupid question, have you updated the raspberry before trying to connect ?

    The message "target type does not match the device in your project" reminds me of that.

    Best regards

  • Peter1983

    Peter1983 - 2019-07-26

    Hi did you get it sorted. I found that ssh has to be enabled in the pi configuration setting to update and connect the pi.

  • djesic

    djesic - 2019-08-13

    Sorry for the delayed reply, I've been on vacation.

    SSH is enabled on the Pi and I can start the runtime:

    [INFORMATION]Β  Β Executing SSH command on pi@ Start runtime system
    [INFORMATION]Β  Β Standard output: Starting codesyscontrol (via systemctl): codesyscontrol.service.

    And I confirmed that the service exists and runs on the Pi

    A stupid question, have you updated the raspberry before trying to connect ?

    I'm not exactly sure what you mean by update here, could you please elaborate?

    Thanks again for your replies

  • eschwellinger

    eschwellinger - 2019-08-13

    online version and versionin your project should fit.
    Update device means - right click ob device tree... see screenshot


    IMG: UpdateDEvice.png

  • djesic

    djesic - 2019-08-14

    After updating the IDE, the Raspberry Pi package and then finally the device, I'm now able to connect!

    Thank you very much!

  • philippludwig

    philippludwig - 2021-07-18

    I am facing the same issue, updating everything did not work. Anything else I can do?

  • eschwellinger

    eschwellinger - 2021-07-18

    check if the plc is running.. by update tool info or top in the plc shell.
    if it is running, install the gateway on pi side and use it to scan your plc... ( add the new gateway by the ip and scan via this gateway)

  • philippludwig

    philippludwig - 2021-07-19

    If you mean the codesys runtime by "PLC", then yes, it is running on the raspberry. Scanning just yields the same error message.


Log in to post a comment.