Codesys Runtime 4.6 or 4.7 in Raspberry PI 4 revision c03115, falls after just few seconds

rcaponi
2023-02-16
3 days ago
  • rcaponi - 2023-02-16

    Hi everyone!
    I'm trying to test the Codesys control (4.6 or 4.7) on a Raspberry PI 4 with 4 Gb of RAM.

    Hardware : BCM2711
    Revision : c03115
    Model : Raspberry Pi 4 Model B Rev 1.5

    Linux raspberrypi 5.15.79-rt54-v7l+ #2 SMP PREEMPT_RT

    My problem is that it is only running for a few seconds.
    If anyone had a similar problem please help me.

    Thank you!

     
  • eschwellinger

    eschwellinger - 2023-02-16

    Is that current version? Bullseye?

     
  • rcaponi - 2023-02-17

    Yes, it is.
    What I don't understand is that the same version works fine on Pi4 revision c03111/c03112.
    I read on the forum, I believe, that the problem is similar to what happened some time ago and solved with the v4.4 version of the runtime.
    But of course this is my guess....

     
  • rcaponi - 2023-02-17

    Hi,
    I have to point out that the problem is not related to the bulleye version.
    The same problem also occurs with the buster version.

     
  • theo-aldescu - 2023-02-17

    Hello,

    Let me present my problem, and let's see if it's similar
    Just got a PI4B. used Raspberry PI imager, put on the latest OS(bullseye 32bit)
    Enabled SSH.
    From Codesys v3.5 SP18 installed the runtime on the PI(runtime V4.7), no problems so far, so i reboot the PI using the codesys reboot target command
    When i tried to go online with the PI, it says that the target can't be found and i need to rescan the network
    If i rescan, i can't find my PI

    If i send a stop command and then a start command to the runtime from codesys via SSH, and then i rescan the network, i find the PI adn i can go online.
    point is, that sometimes after a few second, and sometimes instantly after going online, i get the same error that the target can't be found.

    other than that, i haven't tried anything else, but more than a year and a half ago, i used the first time a Raspberry pi 4B with codesys and it worked like a charm. but i can't remember how i did it and what OS and runtime versions i used.

    and i have no idea what to do right now.

     
  • theo-aldescu - 2023-02-17

    follow up

    i just realized, that while installing the runtime on the PI, it asks me to automatically install an edge gateway, i click ok, and it's the same story if i try to go online using the localhost gateway or the gateway with the PI ip address
    and the message when i try to go online is "no connection to the device. Please rescan your network."

    when i clicked system information i noticed this
    "2023-02-17T17:36:07Z, 0x0000001c, 4, 28, 0, **** ERROR: Invalid session ID. Still other sessions on this channel, do not close it."

    have no idea what it means

     
  • eschwellinger

    eschwellinger - 2023-02-17

    check what happens if you start the runtime manually by
    sudo /etc/init.d/codesyscontrol stop
    then

    cd /var/opt/codesys
    sudo /opt/codesys/bin/codesyscontrol_armv7l_raspberry.bin -d /etc/CODESYSControl.cfg
    for the multicore runtime

    for the SL (without MC ) runtime:
    cd /var/opt/codesys
    sudo /opt/codesys/bin/codesyscontrol_armv6l_raspberry.bin -d /etc/CODESYSControl.cfg

     
  • theo-aldescu - 2023-02-17

    here are the last few lines resulted
    the whole text result is in the attached file

    2023-02-17T17:58:20.900Z: Cmp=CmpRouter, Class=1, Error=0, Info=1, pszInfo= Setting router <instance>2</instance> address to

    (2ddc:9ca0:140c)

    2023-02-17T17:58:20.905Z: Cmp=CM, Class=1, Error=0, Info=34, pszInfo= CODESYS Control ready
    2023-02-17T17:58:20.906Z: Cmp=CM, Class=2, Error=0, Info=0, pszInfo=!!!! no runtime license - running in demo mode(~2 hours)
    ooops... this runtime was built for RASPBERRYPI. Hardware version or firmware version not supported! (-18, 0x00000BB8, 0xFFFFFFFB)
    admin@RPI:/var/opt/codesys $ /etc/CODESYSControl.cfg
    bash: /etc/CODESYSControl.cfg: Permission denied

    sooo the "oops..." message confusez me a lot.

     
  • theo-aldescu - 2023-02-17

    Follow up

    i think i called the command for single core
    but after calling sudo /opt/codesys/bin/codesyscontrol_armv7l_raspberry.bin -d
    i got the same result(correct response in .txt file attached)

     
  • eschwellinger

    eschwellinger - 2023-02-18

    could you give the result of 'ifconfig -a' and 'cat /proc/cpuinfo'

     

    Last edit: eschwellinger 2023-02-18
  • theo-aldescu - 2023-02-18

    sorry for the late reply,
    attached are result of the commands requested(Result_2), and also the result of ipconfig on the windows pc that i work on(win_host)

     
  • rcaponi - 2023-02-20

    Hi,
    attached are result of the commands requested.
    ifconfig -> ifconfig_log.txt
    cpuinfo -> cpuinfo_log.txt
    start runtime (v4.7) -> codesys_log.txt

    My logs are very similar to those reported by Theo.
    From what I see we are both using the 1.5 Raspberry revision.
    Me with 4Gb, Theo with 8Gb.

     
  • eschwellinger

    eschwellinger - 2023-02-20

    thanks for the feedback & information, we try to support the Rev1.5 with the next release

     
  • theo-aldescu - 2023-02-20

    thanks for the help also!
    to be sure i understand, the problem is with the revision of the PI hardware?
    and we hope that in the next version of the codesys runtime the problems are solved?

     
  • eschwellinger

    eschwellinger - 2023-02-20

    yes and yes πŸ‘

     
  • hyet - 2023-07-25

    Hi, since this was an issue on V4.7, i assumed that it would be resolved in V4.8, but unfortunatly, it is still an issue on 4.8. Is there any indications when this will be resolved?

     
  • eschwellinger

    eschwellinger - 2023-07-25

    this is a new/other issue:
    https://faq.codesys.com/pages/viewpage.action?pageId=153321520 should fix it &
    will be solved with 4.9.0.0 release

     
    • hyet - 2023-08-14

      With the raspberry pi 4, i was able to resolve this issue, but not with raspberry pi CM4. is there anything else that we need to take in account?

       
  • ax45 - 2023-07-26

    Same probleme here. Found my Rev1.5 boards work with 2023-02-21-raspios-bullseye-armhf.img and Codesys Runtime 4.8.0.0

    Regards

     

Log in to post a comment.