Can not go online on Linux arm based device

2021-01-15
2021-02-03
  • codesysnoob

    codesysnoob - 2021-01-15

    Hey guys,

    I am using a linux arm based device as PLC and I am running the demo runtime on it. I was able to go online earlier and download the program and test it. But after a few days when I try to go online the PLC software can be scanned through scan network screen but when I select the device I get " No device is responding to the scan request" . Can you tell me what can be done? I even tried to create a new program and connect to it but I still get the same error.

    I am attaching a few pictures for clarification.

    Thanks
    SB

     
  • eschwellinger

    eschwellinger - 2021-01-18

    A solution for this would be to install the Edge Gateway (armhf from store) and then scan would workd again if you use the Edge Gateway.. beside your solution you have found.

     
    πŸ‘
    1
  • eschwellinger

    eschwellinger - 2021-01-15

    Hi,
    I would recommend to delete the bootproject and restart the runtime.
    Maybe this solves it.
    BR
    Edwin

     
  • codesysnoob

    codesysnoob - 2021-01-15

    Hi Edwin,

    Thanks for the response. Can you tell me how do I delete the bootproject? Can I do it through the programming PC that is connected to the PLC device?

    Regards
    SB

     
  • codesysnoob

    codesysnoob - 2021-01-15

    Hi Edwin,

    I found out how to delete the bootproject and restarted the runtime. But I am getting the same error still.
    Can you figure out what else might be wrong with it?

    Regards
    SB

     
  • eschwellinger

    eschwellinger - 2021-01-16

    Hm, which demo runtime is it? Would contact your supplier..

     
  • codesysnoob

    codesysnoob - 2021-01-18

    Hi Edwin,

    It was provided to me through Codesys. But I found some help in the issue and it has been resolved. I just needed to type in the IP address instead of selecting it from the scanned device list and it works.

     
    • kumareasu

      kumareasu - 2021-02-03

      I think you are using Jetson board. Could you please let me know the following details...
      1. What is the CoDeSys Runtime Module you used?
      2. What is the OS?
      3. What is the Jetson Board you have used?

      thanks & regards,
      EK

       

Log in to post a comment.