Raspberry Pi Control SL MC - Restoring License not working anymore!

  • lefish - 2023-07-18

    Hi there!

    I recently upgraded my device from runtime (raspberry, armhf) to armhf (raspberry, armhf).

    I now wanted to restore my license file (CMLicenseNew.WibuCmRaU) which I saved from the same device under runtime

    This appearently does not work anymore. I saw the device now has TWO SoftContainers. I tried both and get the same error.

    This are the SoftContainers now:

    On either SoftContainer I get the same error and no licenses show up within the SoftContainer like the earlier did after restoring the license.

    This is the error:

    Can you help on this please!

    Best regards


    Last edit: lefish 2023-07-18
  • lefish - 2023-07-18

    I have found this link: https://faq.codesys.com/pages/viewpage.action?pageId=1310825

    And it seems to have something to do with me trying to restore a pre license on a post system.

    Can this be the issue?

    As I also backed up the cmact_licenses folder I now tried to replace all the conent from the .cmact_licenses folder with my backed up content from the cmact_licenses folder.

    Is this a legit solution?

    • lefish - 2023-07-19

      I will answer my own question: It is not possible to simply copy the files from cmact_licenses to the .cmact_licenses folder.

      Restoring the license must be done by the license manager within CodeSys.

      So the initial question remains: How can one restore a backed up license in runtime version

  • lefish - 2023-08-08

    One more question on this:

    Am I doing something wrong? I have activated a new license on a device, which has NEVER seen a runtime <
    This worked flawlessly with the license key provided.

    I now tried to reactivate the license from a backed up license file (file extension "WibuCmRaU") on the same device and I get this error:

    This time it is a Raspi 3B with a SL (non MC) license for development.

    Has anyone tried to restore a license the same way it did work on a pre system (I did this hundred times before) on a system successfully?!


    Last edit: lefish 2023-08-08
  • vincentger - 2023-08-21

    Running into the same problem restoring a Runtime device on a now device.

  • eschwellinger

    eschwellinger - 2023-08-24

    you need to use 'my question ' in the CODESYS store


Log in to post a comment.