White Background during Frame switching

2020-09-05
2020-09-09
  • marsmännchen

    marsmännchen - 2020-09-05

    Hello,
    i'm nearly done with my Webvisu for the shutters but a strange behavior appeared.
    I'm using Frames to switch the different pages (Light,Shutters,Mainmenue,..)
    When i switch from "Main" to "Light" it is a perfect fast transition.
    But when i switch between the two shutter visu's a very short moment the Background is white.
    Sorry, I can't explain any better.
    Does anyone have a clue what i have done wrong?

    Edit: Now I noticed, if i switch the Visu in the Codesys Runtime it works normal, means no white background for a short time.

    Greetings
    Patrick

     

    Last edit: marsmännchen 2020-09-05
  • dkugler

    dkugler - 2020-09-05

    what do you mean with runtime? switch from the visu client in the yprogramming system at the PC or change the variable by IEC code at your plc?

     
  • marsmännchen

    marsmännchen - 2020-09-06

    I mean when i switch between two frames in the Visu. But the short moment of white background happens only when i'm using the Visu in a Browser (no matter which Browser) when i switch between the frames in the Codesys Programm (the Tab with the Visu when im online) it works perfekt.

     
  • dkugler

    dkugler - 2020-09-06

    Programming System is updated every 200ms only, so probably you can't See the white screen there. Browser normally update faster, depents to the settings of webvisu and tasks. Do you have a big picture as Background, that has to be downloaded from the Webserver, which is different from shutter to shutter? Whats your plc? A Raspberry Pi?

     
  • marsmännchen

    marsmännchen - 2020-09-06

    yes, there is a big background .My PLC is a PFC200 2.nd Generation.Can you take a look at my project? Maybe you are right and i expect to much from the webvisu...

     
  • dkugler

    dkugler - 2020-09-06

    the reason are the group boxes! After 1hour thinkering i got it. I changed the project to Codesys Control Win and deleted all wago things. After download to the Control Win and opening 127.0.0.1:8080/webvisu.htm I got the same effect like you. I placed one groubox at the mainmenue and the white background appears there too! So the PFC ins't the problem!
    Send the project to codesys support --> Meine Frage

     

    Last edit: dkugler 2020-09-06
  • eschwellinger

    eschwellinger - 2020-09-07

    thanks for sending the project via 'my question' for me it looks like enable
    'Support client animation and overlay of native elements' in the visumanager will solve it.
    Regards
    Edwin

     
  • dkugler

    dkugler - 2020-09-07

    once more a little unimpressive checkbox with unsuspected effects 😎 now it works..
    Thank you Edwin 👍

     
    • m.prestel

      m.prestel - 2020-09-08

      That checkbox is doing way more then just being unimpressive with a unsuspected effect ;)
      The checkbox changes the way all visualization elements are drawn in the client from a global drawing context to a drawing context per element.

       
      👍
      2
      • dkugler

        dkugler - 2020-09-08

        is it possible for you or the promotion people to make youtube videos, explaining how the visualization is working in the background and how you as experts use it? That will be great! And I haven't seen a offer for a training about creating good visualizations with Codesys?

         
        • m.prestel

          m.prestel - 2020-09-09

          As far as I know there are currently some visu trainings in the making.

          Never let a developer design a website. Mine always look ugly ;)

           
  • marsmännchen

    marsmännchen - 2020-09-07

    It works so beautiful i could cry😭.Thank you!!

     

Log in to post a comment.