Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Webvisu freeze

Chris.O
2021-08-24
2021-08-25
  • Chris.O

    Chris.O - 2021-08-24

    Hi,

    I have a problem with my webvisu.
    I'm using CoDeSys 3.5.17.0 with a Kontron CU (Runtime 3.5.16.20)
    I loaded my program and everything is working fine. After a short time (10-30min) my Webvisu is freezing and I can't reconnect. It looks like that my Webserver is crashing and not starting again.
    Inside the codesys visualisation everything is working fine. So I have no exception...

    I tried to check the log file but I have a problem there (may this could be the root of the problem). I tested my software without the IO's which are connected usually via CAN-BUS.
    Because I haven't connected the CAN-Devices my log-file is flooded with log messages from my CAN-BUS (every 10ms)
    Could this log-File cause such a problem? At the moment I excluded the CAN-Devices from my program and it seems that the freeze will not happen any more.

    Have anyone similar problems?

    I also increased the Buffer size and the update rate without success (like mentioned in an other post).

    Would be nice if someone have a solution for me :-)

    BR Chris

     
  • m.prestel

    m.prestel - 2021-08-25

    Hey Chris,

    I am not aware of any issue.
    Could it be that the CAN-BUS is a high priority task and writing to the log results in a lot of IO actions which reduce the speed and the WebServer task simply is not running?

    I am not an expert at all with CAN-Devices.
    @eschwellinger @i-campbell do you guys have any idea?

    Best regards,
    Marcel

     
  • eschwellinger

    eschwellinger - 2021-08-25

    not really, but need probably to be investigated on this device, due other devices do not have this problem. (Would ask Kontron to help to do this)

     
  • Chris.O

    Chris.O - 2021-08-25

    Hi Marcel, Hi Mr. Schwellinger,

    thank you for your fast response.

    I have no influence on the priority of the CAN-BUS-task if I'm right...

    As I described I excluded the CAN-Devices from the build and then everything was fine. Now I included it again and the logs came back (of course). But the Webvisu is still running without problems?!

    I did not change anything else... reset origin etc. I tried before as well. So I can't find a reason for that behaviour.

    I will ask Kontron also if they know this problem.

    Is there a way to restart the webserver manually if this happens again? In past I did then a online change or a Download and then it starts again...but on costumers side this will not allways be possible.

    BR Chris

     
  • m.prestel

    m.prestel - 2021-08-25

    Hey,
    No there is no public interface to restart the webserver right now..

    Best regards,
    Marcel

     

Log in to post a comment.